--source include/not_valgrind.inc --source include/big_test.inc --echo # Bug #31154128 INPLACE UPGRADE 5.7 -> 8.0. FAILS WITH "ERROR IN FIXING SE DATA" SPECIFIC CASE --echo # --echo # This test upgrades a 5.7 database with a table in a general tablespace --echo # having a FULLTEXT index to 8.0 --echo # --echo # Stop the running server --source include/shutdown_mysqld.inc --echo # Unzip the datadir # This zip file contains a data directory generated on 5.7 with following commands: # $ mysqld --initialize-insecure --innodb-log-file-size=4194304 # $ mysqld --innodb-log-file-size=4194304 # CREATE DATABASE test; # USE test; # CREATE TABLESPACE `ts1` ADD DATAFILE 'ts1.ibd' Engine=InnoDB; # CREATE TABLE t1 (c2 text, FULLTEXT idx (c2)) TABLESPACE ts1; # INSERT INTO t1 VALUES ("hello"),("world"); # SHUTDOWN; --let $zip_filename = data57_fts_shared_tablespace let $DATADIR1 = $MYSQL_TMP_DIR/$zip_filename; --exec unzip -qo $MYSQLTEST_VARDIR/std_data/$zip_filename.zip -d $DATADIR1 --echo # Restart the server with the unzipped datadir --replace_result $DATADIR1 DATADIR --let $wait_counter=3000 --let $restart_parameters = restart: --datadir=$DATADIR1 --innodb_page_size=16k --source include/start_mysqld.inc SHOW TABLES; SHOW CREATE TABLE t1; SELECT * FROM t1; SELECT * FROM t1 WHERE MATCH(c2) AGAINST("world"); --echo # Cleanup --echo # Shutdown server --source include/shutdown_mysqld.inc --echo # Remove copied files --force-rmdir $MYSQL_TMP_DIR/$zip_filename --echo # Restart the server let $restart_parameters =; --source include/start_mysqld.inc