################################################################################ # The intent of this test is to verify if the validations that were # created within the Group Replication plugin in the startup process # are fully functional. # # It will test binlog disabled failure. # # Test: # 0. The test requires one server. # - Disable log_bin in option file. # - Install plugin at startup. # 1. START GROUP_REPLICATION must fail due to GR incompatible value. ################################################################################ # The section below is present in "have_group_replication_plugin.inc." # But since this test is evaluating the absence of certain configurations, one # is not able to use that file since it enforces the existence of such # parameters in the server. if (`SELECT @@have_dynamic_loading != 'YES'`) { --skip Requires dynamic loading } if (!`select count(*) from information_schema.plugins where PLUGIN_NAME like 'group_replication'`) { --skip Need GROUP_REPLICATION plugin } --let $assert_text= Binlog is disabled --let $assert_cond= [SELECT @@GLOBAL.log_bin] = 0 --source include/assert.inc --echo # --echo # Test if binlog disabled will fail. --echo # --error ER_GROUP_REPLICATION_CONFIGURATION START GROUP_REPLICATION; call mtr.add_suppression("Binlog must be enabled for Group Replication"); call mtr.add_suppression("You need to use --log-bin"); call mtr.add_suppression("slave_preserve_commit_order is not supported unless both log_bin and log_slave_updates are enabled.");